我们来自五湖四海,不为别的,只因有共同的爱好,为中国互联网发展出一分力!

wordpress升级需谨慎,升级需备份

2014年12月30日18:45 阅读: 2194 次

标签: wordpress升级需谨慎,升级需备份

可能是强迫症作怪,有个更新亮着总觉得不舒服。于是就大胆的升级4.1。也是够大胆的,只把数据库备份了,文件没有备份。升级完成后果断503错误 了,这弄得我折腾了大半天。恢复数据库,替换文件反反复复来了几次。还是503,后面想到了可能是插件有问题。于是百度了在数据库禁用插件的方法,果然就 O啦。所以啊升级需谨慎,升级需备份。出了问题直接数据库和文件一起恢复。

正确的版本升级应该是,备份数据库和文件,然后禁用所有的插件后在执行升级。这样也避免不了升级过后启用插件造成的不兼容。所以升级以后一个一个插件启用。出现问题后在执行数据库修改。

一般来说,在主机空间控制面板都会提供诸如 PHPMyAdmin 之类的 MySQL 数据库修改软件,本文就以 PHPMyAdmin 为例。

记录 WordPress 插件信息的表位于:wp_options 表中的 active_plugins 字段,active_plugins 的值记录着插件使用情况。

如果禁用所有插件,只需要用 a:0:{} 来代替 active_plugins 的值即可。


?

如果是升级后启用某一个插件造成问题,就删除其中一项。比如我这次升级后503错误就是由于我使用的GravatarLocalCache这款Gravatar头像缓存插件引起的,就删除

1i:4:s:41:"gravatarlocalcache/GravatarLocalCache.php";

GravatarLocalCache这款插件已经2年没有更新的,但是我觉得是头像缓存插件里最好用的一个。升级wp后不能使用了也是很遗憾的。就算慢的要死,现在也只能使用多说的镜像了。

更多网站建设,敬请关注http://www.chncto.com/jianshe/

分享到: 更多
?2019 安全焦点 版权所有.